Home Page Forums Technical Discussion Audio Working in Linux Finally


Viewing 1 post (of 1 total)
Audio Working in Linux Finally
2023-01-13 22:33:15
Replies: 0 | Views 222 | Favorites: 0 | Subscriptions: 0

I am running Fedora fc37 on kernel 6.0.18-300 and after a lot of tweaking around in alsamixer, I have audio playback working. Still no built in microphone access. I had tried kernel 6 in Ubuntu but it never sorted the audio issue out.

card: sof-essx8336

chip: Intel Jasperlake HDMI

The available mixers are labled weird though. The master mixer is called Headphone, even if you don’t have headphones plugged in. The second mixer is also called Headphone. The third one is called Speaker, and cannot be moved up or down, though it can be muted and unmuted.There are a lot of other control mixers. And I do mean a ridiculous number of mixers. There seems to be a lot of internal DAC stuff, probably related to the HDMI audio output.

The mixer shows controls for the microphone and there are individual mic boost and capture options that can be selected. Honestly, alsamixer looks terrible but it shows a lot of configuration ability for this sound card.

The capture options (F4) show what appear to be microphone effects as if there is a virtual compressor for the microphone to enhance the sound recorded through the microphones.

The only reason I say the mic isn’t working is because in the actual system settings under sound there is no input device even selectable.

Other oddities exist with this sound setup. You might have to fiddle with the volume mixers to get everything sounding OK.

Viewing 1 post (of 1 total)
Post a new Topic