Home Page Forums After Sales Services Overheating issue and cannot update iPlay40

Viewing 9 posts - 1 through 9 (of 9 total)
Overheating issue and cannot update iPlay40
|
2021-06-01 04:18:50
Member
Starter
#1F
Replies: 8 | Views 1140 | Favorites: 0 | Subscriptions: 2

Hi, I hope I can find some help here as I am having a couple of issues with my iPlay 40.

Firstly, I cannot use the OTA or local updates. I am on version V1.0_20210105-1554. Wireless updates tells me there is a new version (V1.0_20210121-1556), I download it, install it and I get an error message during installation.

I have tried downloading the newest version and install it locally, but this also fails.

My biggest issue is that when playing games, I sometimes get an error message that the tablet is overheating and it shuts off.  The strange thing is that it doesn’t even feel hot to touch!

I was hoping that an update might solve the issue, but I cannot get it to update. I tried to update connecting through the PC, but I cannot find USB drivers for it either.

Any help would be much appreciated.

Member
2021-06-29 11:00:03
#2F

I have the same problem….but I found the solution and fixed mine. All I did was add some thermal tape to the inside of the back cover (over the cpu) and now I get better temperatures. It no longer turns off.

 

Member
2021-07-03 22:59:48
#3F

you should have done ifixit tear down video/guide yo 😀

Member
2021-07-06 17:24:59
#4F

Please if anyone have a fix for this problem .

 

I just buy the tablet a few days ago for doing office works .

Member
2021-07-06 17:25:56
#5F

Please post a guode to how to disasemble the tablet .

Member
2021-07-10 23:19:52
#6F

Quote #5F by @MikazuchiLuke:

Please post a guode to how to disasemble the tablet .

The back is held on by glue and is pretty thin….it’s does not snap into place. Look on Google for a picture of the tablet taken apart for reference and locate cpu…..then just buy some thermal tape and place a long strip on the inside of the back over that will sit directly over the cpu, then glue it back together. Don’t bother with Bangood….their customer service is terrible and will get u nowhere.

Member
2021-09-13 17:43:36
#7F

Had the same issue I rebooted the device and used a different launcher after reading else where this fixed the problem and guess what it fixed it …I used it for 6 hrs straight no problems n gave it a good run it performs really good now .

  • Hope this helps .
Member
2021-09-13 18:06:47
#8F
Member
2021-11-16 08:17:00
#9F

Just install simple system monitor will solve the issue, I have try so far so good

Viewing 9 posts - 1 through 9 (of 9 total)
Post a new Topic