Home Page Forums Technical Discussion BUG in Alldocube’s Android 13 – external mouse (wired, USB or BT) switches X & Y axis

Viewing 1 post (of 1 total)
BUG in Alldocube’s Android 13 – external mouse (wired, USB or BT) switches X & Y axis
|
2024-05-19 14:42:16
Member
Starter
#1F
Replies: 0 | Views 72 | Favorites: 0 | Subscriptions: 1

My Device
“About Tablet”  Model:  iPlay 50 Android Version: 13  Build #:  T1030_V1.0_20240220
“System Update”  Current: T1030_V1.0_20240220_20240220-0040  Last Check: 2024-05-12
“Back Panel”  T1030B128GB23232120034

 

There is a well-documented BUG in an early release of Android 13, which some OEMs (Lenovo being the biggest) did not “fix” before implementing its own branch of Android 13.  Most other Android tablet OEM’s have included the BUG fix.  <span style=”text-decoration: underline;”>Sadly it appears that Alldocube has not done so thus far</span> (as of the latest system update on 5/12/2024.

<span style=”text-decoration: underline;”>The Android 13 BUG is falsely switching the mouse’s X & Y axis when using ANY external mouse in a non-Android app environment. </span> The bug does NOT appear while controlling the Android OS or in an Android App.  However, it occurs in Microsoft’s Minecraft on Android.  This appears to have affected tablets from OEMs that have the “native” screen position set to landscape (such as the iPlay 50).  AGAIN… Android ALREADY FIXED this bug, but any OEM (Lenovo & Alldocube sadly) who “branched” before the fix STILL suffers from the bug.

Loyal owners of your Android 13 tablets will GREATLY APPRECIATE you fixing this issue!  Thank you.

 

Here are a few sites that document the issue very well (which I am experiencing on iPlay 50):

GitHub:  https://github.com/moonlight-stream/moonlight-android/issues/1240 

Reddit:  https://www.reddit.com/r/GeForceNOW/comments/180z7dx/mouse_not_functioning_correctly_on_geforce_now/

Lenovo: https://forums.lenovo.com/t5/Lenovo-Android-based-Tablets-and-Phablets/Lenovo-Tab-P11-Second-Gen-Bluetooth-Mouse-Axis-Swapped/m-p/5264557?page=2  
“The issue is this: A mouse connected to the  [Alldocube]   Android 13 device will function correctly and as expected within the Android OS and within Android apps – except WHILE streaming any Windows environment or mouse-controlled device or application. At which point, mouse movement sent from the client device (the  [Alldocube]   Android 13 device) to the host device (Windows PCs / GeForce Now servers) will be incorrect, with X/Y axis being swapped. That, in turn, makes any connected mouse completely unusable when streaming desktop or games, thereby rendering many important applications unusable. As it stands,  [Alldocube]   devices running  [Alldocube]’s Android 13 build cannot be comfortably used to stream Windows PCs or any mouse-controlled host device, because of it.”

Mojang (Microsoft):  https://bugs.mojang.com/browse/MCPE-177342?page=com.atlassian.jira.plugin.system.issuetabpanels%3Achangehistory-tabpanel

Viewing 1 post (of 1 total)
Post a new Topic
SUBSCRIBE NOW